Intermittent Performance Degradation – LegendGames API

Incident Report for LegendGames24 Status

Update

The previously observed performance issues affecting the LegendGames API have escalated.
Users may experience increased error rates, elevated latency, or temporary request failures.
Our engineering team is actively investigating and working to stabilize the service.
Further updates will be provided as more information becomes available.
Posted Feb 21, 2026 - 19:08 UTC

Monitoring

We are currently observing intermittent performance degradation affecting the LegendGames API.
Some requests may experience increased response times or occasional errors.
Our team is actively monitoring the situation and investigating the underlying cause.
Temporary disruptions may occur while we continue to observe system behavior.
Posted Feb 21, 2026 - 17:17 UTC
This incident affects: LegendGames API.